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After learning this chapter, you will be able to
• be familiar with the working environment of electronic spreadsheets
• manage the files of electronic spreadsheets
• state the advantages of using electronic spreadsheets
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1

Introducing Spreadsheet



Chapter 1 Introducing Spreadsheet 

1.1  Introduction to Microsoft Excel

Microsoft Excel is a popular spreadsheet software, it is an effective tool for organizing and 

calculating numerical data. It helps us manage data in our daily lives, such as personal 

expenses records. At schools, they are used for organizing and calculating students’ 

examination marks. 
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Excel 2003

Gallery 1.1 Microsoft Excel



1.2  Working Environment of Excel

Working environment in different versions of Excel is similar. Please match the labels to the 

corresponding position below.
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Review 1.1 Working environment in Excel 2007

Match the labels.

Cell

Cell

Formula bar

Formula bar

Ribbon

Ribbon

Row heading

Row heading

Column heading

Column heading

Title bar

Title bar



1.3  The advantages of using spreadsheet

Compare below two mark sheets used by a teacher.
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Which one is more efficient to store and process the student examination marks? Why?
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Review 1.2 Advantages of using electronic spreadsheet

Check Answer

Question 1 of  2
Which method is more efficient?



1.4  Spreadsheet basic

The two most common types of data used in a spreadsheet are text and numbers. We can 

enter the data directly into a cell and then press ENTER key.

A cell address (e.g: B3) is formed by the column letter (e.g: B) followed by the row number 

(e.g: 3). A cell range (e.g: A2:B5) is formed by two cell addresses separated by a colon ( ‘:’ 

means ‘to’) which is used in the function.

When all the data is entered, select 

File > Save As... . Enter a file name 

for the spreadsheet, and save the 

file in Excel Workbook (*.xlsx) 

format.
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Review 1.3 Cell references in Excel
Question 1 of  2

Match the labels

C6

C6

B2

B2

E4

E4



Automatic update of data

If formulae are used to add the data in a spreadsheet, the output will be updated (re-

calculated) automatically when changes are made to the data.

1.5  Data sorting

Data can be rearranged easily in a specified order 

in an electronic spreadsheet. This process is known 

as data sorting. 

First, select a single cell within the range, then 

choose Data > Sort command.
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If the value in A1 change to 100, then.... The value in C1 will update to 556 automatically.
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Original set of data (sorted by class number)

Gallery 1.2 Data sorting
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Movie 1.1 Sorting in Excel



1.6  Filtering

As the number of records in a table grows, it is very difficult to look for records we want. 
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Show records matching English name that start with Chan.

Gallery 1.3 Filtering



Filtering is a function to select and display the records meeting the criteria specified by a user, 

leaving the rest of the records hidden.

Microsoft Excel automatically identifies the data type in a column of a table and displays 

different filtering options for the respective data types.
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Movie 1.2 Filtering in Excel



Review 1.4 Automatic update

Check Answer

Question 1 of  2
To obtain updated result of the sum of cell A1 and B1, what should be typed in cell C1?

A. A1+B1

B. =123+456

C. =579

D. =A1+B1
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After learning this chapter, you will be able to
• change column width and row height of a spreadsheet
• merge and split cells in a spreadsheet
• format the text and number displayed in the cell of a spreadsheet

CHAPTER 2
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Editing and Formatting



Chapter 2 Editing and Formatting Spreadsheets 

2.1  AutoFill

Electronic spreadsheets provide an AutoFill function which helps us fill in a series of cells easily. 

Text, numbers and dates can be filled using the fill handle (a tiny solid square located at the 

bottom right corner of a cell).

Other forms of series (e.g. odd number series, weekday series, a mix-up of text and numbers 

can also be filled using AutoFill function.
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Classwork Using AutoFill function to create a monthly calendar

Step 1: Start Microsoft Excel and create a new spreadsheet.

Step 2: Enter Sun in cell A1. Drag the fill handle to cell G1 to fill the remaining days of 

week in row 1.

 

Step 3: Enter the numbers 1 and 2 in cells A2 and B2 respectively. Select cells A2 and B2 

and drag the fill handle to cell G2. The numbers 3 to 7 will be filled in row 2 

automatically.
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Step 4: Similarly, enter the numbers 8 and 9 in cells A3 and B3 respectively. Fill the third 

row with numbers up to 14.

Step 5: To fill the remaining rows, select cells A2 and G3 and drag the fill handle to row 5.
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Step 6: Enter the remaining days 29 and 30 in cells A6 and B6 respectively.

Step 7: Select row 1 by clicking its row heading. Click the Both button.

Step 8: Select column A by clicking its column heading. Click the Font Color button to 

change the text colour to red.

Step 9: Select cells A1 to G6. Click the Borders button to apply all borders.

18



2.2  Changing Column Width

The width of a column affects the way in which data is presented in a spreadsheet. If a column 

is not wide enough too display its content, confusion may occur. In the following figure, cell A2 

contains the text ‘Computer Literacy’ which is too long to be contained with column A.

It appears that cell B2 contains text extended from cell A2, even though cell B2 is actually 

empty. However, entering S1 in cell B2 gives the following:

For numbers that are too long to fit in a column, the symbol ‘#’ will be displayed as follows:

The width of a column can be changed in several ways. The simplest way is to drag the 

boundary between adjacent column headings. Point to the boundary, so that the cursor 

changes to . Dragging the boundary towards the right can increase the column width.
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Double-click the boundary and this can adjust the column to be wide enough to fit the stored 

content. This may increase or decrease the column width depending on the length of the stored 

content.

  

Alternatively, select Format > Column > Width... in Menu bar can also change the column 

width. This command is useful for changing the width of a group of selected columns.

 

2.3  Changing Row Height 

Similarly, the height of a row can be changed by dragging or double-clicking the boundary 

between two adjacent row headings. To change the height of more than one row, select the 

rows by clicking the row headings. Select Format > Row > Height and enter a new value for 

row height.
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2.4  Merging and Centering Cells 

Data entered in a single cell can be centred and spanned across several columns or rows. This 

can be done by combining or merging cells. For example, the text ‘Computer Literacy’ is stored 

in cell A1. Select cells A1 to G1.

 

Click the ‘Merge and Center’ button on the Formatting toolbar.

Cell A1 now spans across column A to G, and its content is centred.
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Alternatively, we can select Format > Cells from the Menu bar. In Alignment tab of Format Cells 

dialog box, select Center for ‘Horizontal text alignment’ and check the ‘Merge cells’ box. To split 

a merged cell, simply uncheck the ‘Merge cells’ box.
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2.5  Applying Cell Borders 

Cell borders make individual cells more distinguishable and help us read data easier. Select the 

cells to apply borders and click the ‘Borders’ button on the ‘Formatting’ toolbar.

Select the appropriate border, such as the ‘All Borders’, from the ‘Borders’ menu. To remove cell 

borders, click the ‘No Border’ button form the menu.
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2.6  Formatting Text and Number 

Similar to word processor, the text in a spreadsheet can be aligned left, center or right. Note 

that by default, numbers are aligned right in a cell while text is aligned left.

The font and size of a cell are set by the ‘Font’ pull down menu and the ‘Font Size’ pull down 

menu respectively. Note that when the font size is increased or decreased, the row height is 

automatically adjusted.
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The font color of the text in a cell is set by clicking the ‘Font Color’ button. A color palette will 

be displayed and the necessary color can be selected.

Numbers stored in the cells should be formatted properly to reflect the type of value 

represented. For example, number representing money should be displayed in currency style 

(‘$’ sign and 2 decimal places). The type of currency symbols displayed depends on the 

regional and language settings of the user’s computer.
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For decimal numbers, the value displayed in a cell depends on the column width. In the 

example below, the number ‘123.456789’ is displayed as ‘123.45678’.

Clicking the ‘Increase decimal’ button will increase the number of decimal places displayed and 

column width.
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Clicking the ‘Decrease decimal’ button will decrease the number of decimal places displayed.

Note that both ‘Increase decimal’ and ‘Decrease decimal’ functions affect only the displayed 

value of a cell, rather than the actual stored value.
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2.8  Conditional Formatting 

Adding conditional formatting to a cell in Excel allows you to apply different formatting options, 

such as color, to a cell or cells based on the data in the cell(s).

Step 1: Select the cells that require conditional format.

Step 2: Choose Conditional Formatting > Highlight Cells Rules > Less Than...

Step 3: Enter the value.
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Original set of data

Gallery 2.1 Conditional Format
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Movie 2.1 Conditional Formatting in Excel



After learning this chapter, you will be able to
• enter and copy formulae in spreadsheet
• use spreadsheet functions to calculate the sum, the average, the maximum and the minimum value
• briefly describe the idea of relative cell addressing

CHAPTER 3
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Chapter 3 Calculation 

3.1  Using Formulae

One of the main advantages of using spreadsheets is the ability to perform calculations 

automatically. Every formula begins with an equal sign (=). The following show some examples 

of mathematical operators.

Mathematical operator Meaning Formula Displayed Result

+ Addition =2+3 5

- Subtraction =5-2 3

* Multiplication =12*4 48

/ Division =10/2 5

^ Exponentiation =4^2 16

() Brackets =(2+3)*4 20

Formula input is completed by pressing ENTER.
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3.2  Using Cell Address in Formulae

Cell addresses (rather than actual number) can be used in formulae so that the values stored in 

cells are calculated. In the spreadsheet below, cell C1 stores the formula =A1+B1 which adds up 

the values stored in cells A1 and B1.

Cell addresses can be easily entered in formula by pointing them. After starting the formula 

with equal sign (=), just click the specified cell. The corresponding cell address will be entered 

into the formula. Press ENTER to complete the formula.

3.3  Using Functions in Calculation

Many built-in functions are provided by Microsoft Excel. The functions are used to facilitate the 

input of formulae. When the built-in functions are used for calculation, the results are shown 

directly in the corresponding cells.
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3.3.1 Using SUM Function

The SUM function adds up the values stored in one ore more cells.

For example, cell E2 stores the formula =SUM(A1:D1), which adds up the values stored 

in cells A1 to D1.

Cell address used in the SUM function can be entered by 

clicking and dragging. For example, after entering =SUM( 

in cell E1, click cell A1 and then drag to cell D1. The cell 

range A1:D1 will be entered in the formula.
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Movie 3.1 Editing formula in Excel



3.3.2 Using AVERAGE Function

The AVERAGE function calculates the 

average value for a group of cells.

For example, cell D1 stores the formula =AVERAGE(A1:C1), which calculates the average 

value of cells A1 to C1.

3.3.3 Using MAX and MIN Functions

The MAX and MIN functions can be used to find the largest and smallest value in a 

group of cells respectively. 

For example, cell B4 stores the formula 

=MAX(A1:D1) which finds the largest value 

within cel ls A1 to D1. The formula 

=MIN(A1:D1) in cell B3 gives the smallest 

value within cells A1 to D1.
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3.3.4 Using COUNT Function

The COUNT function counts the number of cells in a selected range that contains 

numbers. 

For example, cell A3 stores the formula =COUNT(A1:D1). It counts the number of cells 

which stores a number from cells A1 to D1.

3.4  Copying Formula

To copy a formula to adjacent columns or rows, drag the fill handle of the cell which stores the 

formula. In the following example, the formula =SUM(A1:A3) stored in cell A4 is copied to cells 

B4 and C4.
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Note that the formula copied to cells B4 and C4 adds 

up the numbers directly above them, rather than the 

numbers stored in cells A1 to A3. Check that cell C4 

indicat ing cel l addresses in the formula is 

automatically changed from A1:A3 to C1:C3. This is 

known as relative cell addressing.

In contrast to relative cell addresses, absolute cell addresses remain unchanged even if the 

formula is copied to another cell. 

Absolute cell address is denoted by the symbol $, such as $A$1, which means that column A 

and row 1 are fixed. For example, if the formula =SUM($A$1:$A$2) in cell A3 is copied to cell 

B3, the content of cell B3 will also be =SUM($A$1:$A$2).
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Movie 3.2 Using Rank function in Excel (Use of Absolute Cell Addressing)



Review 3.1 Concept questions

Check Answer

Question 1 of  2
Which of the following functions is different from the others?

A. =A1+A2+A3+A4+A5+A6

B. =SUM(A1:A6)

C. =SUM(A1,A6)

D. =SUM(A1:A3,A4:A6)

E. =SUM(A1+A2+A3,A4:A6)

F. =SUM(A1:A3)+A4+SUM(A5:A6)
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After learning this chapter, you will be able to
• state the advantages of using charts to present data
• explain how to operate and edit charts by location, size, title and format
• identify the features of different chart types, including bar charts, line charts and pie charts

CHAPTER 4
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Chapter 4 Charts 

4.1  Creating Charts

Charts can be used to visualize the relationship between data. A chart must include at least one 

data series.

A chart can be created by selecting the group of cells which store data, then select Insert tab, 

then select one of the chart type in the Charts group.
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Each type of chart has advantage over the other types to present certain kind of information. 

Before creating a chart, we should choose the chart type carefully.
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Column chart

A column chart is useful for comparing values, such as the number of students getting a 

particular grade in an examination.

The length of the rectangular bars is proportional to the value they represent.
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Choosing between 2D charts and 3D charts

Microsoft Excel allows users to present most of the chart types in 3D. A 3D chart is apparently 

more attractive, but the perspective view may distort the scale of a figure. Therefore, a 3D 

chart cannot show the correlation between data as good as 2D chart.

In general, a 2D chart is used for data analysis and presentation requiring clear visualization of 

the relationship between data. A 3D chart is used for marketing, advertisement and illustration 

when visual impact on users is more important.
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Pie chart

A pie chart is best used for presenting data that is a percentage of a whole. However, it can 

only include one data series.
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Line chart

A line chart is useful in presenting the changes of data over a period of time, such as monthly 

average temperature of a city. It can include more than one data series.
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Review 4.1 Choosing the right chart

Check Answer

Question 1 of  3
Different types of data can be presented by different charts. Match the following data series with the suitable chart types.

A

A

B

B

C

C



4.2  Editing Charts

Chart title, legend and data labels are important in describing the data presented in a chart.

The toolbar options will be changed automatically when different chart type has been changed.

In the following demonstration, we are going to create a simple 2D column chart which shows 

the browser hits to the school web site.

Step 1:

Select the chart data, then click the Insert tab.

Step 2:

Click the Column button in the Charts group, then choose a 2D Column chart.
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Under the Design Chart Tools group, choose an appropriate Chart Layouts.
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Step 3:

Type in the chart title and Axes label.

Step 4:

In the Axis Options (Under Vertical Axis 

Option), change the Minimum value (e.g. 

20000). You may change the Number format 

also.
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Step 5:

Select the data series and choose Fill option (Gradient fill).
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Step 6:

Fill color in the plot area.

You may even use a photo in the chart area.
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Movie 4.1 Editing chart in Excel



Review 4.2 Concept question

Check Answer

Question 1 of  2
Which type of chart is best suitable to display the trend over time?

A. Column chart

B. Line chart

C. Pie chart

D. Bar chart
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